Mudrunner crash with steering wheel (Epic Games)

When i have my steering wheel (HAMA uRage GripZ Racing Wheel) plugged in and when i launch the game it will open but after 1 second it will close. I tried to plug in wheel when already in game but that option "use primary device" in wheel controls wasn't able to be checked but i clicked few times in the check box and my game crashed. My steering wheel works fine on my friends pc but on mine game seems to crash. It used to work on mine but now it doesn't for some reason. Please fix that.


Could you please provide DxDiag (a detailed guide on how to do it:
and C:\Users*username*\AppData\Roaming\MudRunner\Log.txt at

@Jole_Nele i have a very simular wheel and i had that problem too. Basically, when i downloaded drivers for the wheel, the game would refuse to launch. If you downlaoded the drivers for the wheel, try uninstalling the drivers. If the wheel worked before when you didn't have drivers, then got drivers and it stopped working, i had the same issue. The first thing i tried was uninstalling the dirvers, but sadly, the drivers had changed something, and i had to reinstall windows, and now it works again. I would say this is the best way go around that, but there may be better ways, but i would doubt so. Hope this helps.