PTS Update 11/01/2021 (12.1)

International paystar 5600TS allwheel drive not present if bought, the front axles have visible diffs but when try to enable it says not installed
Ksiva p:4d917, this was also the case before the last januari update

last edited by oldevil66

@idiocracy said in PTS Update 11/01/2021 (12.1):

@HorstOnAir said in PTS Update 11/01/2021 (12.1):

which update? Is this a joke?


It maybe a small update but it fixes a major loading issue that prevented A LOT of people including me from playing the new map due to some issue with our saves.

I am sorry, but this update from today in my eyes is quite clear means "Hey, since we've being away till 11 January, plus a considerably gap of a solid 'game work and update' since the release of phase 2, have this minor update with only 3 things tweaked. Therefore we can show that we did something"

Don't get me wrong, everybody needs and deserve vacation, that is not my point. However the team need to revisit live service support plan/agenda for this game. The gaps of new bugs introduced by new update until they get a proper fix are increasing phase by phase.

Paystar not working AWD yet.
Crane way too sensitive when turning or twisting around with directional pad when caring the log.

last edited by Henriquetavares

@enovikova @Jellyfoosh i realize this is probably like standing on a mountaintop, screaming into the night sky and expecting a response, but - can we at least get a very rough estimate of a timeframe of when we can expect Season 3 / Phase 3 release? February? March? September?

We don't need a time frame for a live version release of phase 3, we need a dev team that actually tests an update before releasing it...
The fact that the list two updates for the pts has made it an unplayable embarrassing mess should be enough for the team to stop, take notice and start doing things properly...

This latest update literally fixed nothing...
-Constant crash dumps
-checking permissions bug
-Nat type bug (no one should have forward ports for this online to work, not to mention I've had mate forward ports and still get the bug)
-coop won't work at all
-steering wheel ffb should be zero when in any kind of menu

That's just a small list of a large list that needs fixing asap...

We need to be able to start the game, start coop and play it to help you guys find the issues properly...

Not good enough..

Still getting the crash dump popup a few seconds after I launch the game. Sigh.....

Where did the radar trailer go from the live game ????? 11.0

It works on PTS and can be purchased anywhere, but in the live 11.0 game, even what it had so far is gone after completing the quest ???????
It's an idiot BUG again that they put in instead of repairing the existing ones !!!!!!!!!
It would be good if they could fix what worked well MONTHS BEFORE !!!
I can't restart the quest either because it also disappeared from the list !!!!!!
This is already a VICC category that the creators cultivate .....
With each fix, they generate new bugs that break the game ......
How much longer do you have to wait months or years to fix .....
There is no need for new things to make existing ones work, especially those that have been working for a long time ....
Outrageous the whole attitude .....

Because in the live 11.0 game this feature doesn't work for me, but I think no one ....
I only see this every time I buy a trailer ....

alt text

last edited by endy papp

Same here, crashes right at menu's every single time 😞

At least they removed some of the biggest bolders from the streets on the first michigan map with the update 12.1 Good desicion. 👍

But please fix the video settings! - they are still not saveable...

last edited by bellerophon

Thanks for the small update, I'm now able to play with my main save without infinite loading screen.

@Jellyfoosh Managed to finally get into Wisconsin after latest update. Still get the error report box coming up, so just licked outside box and entered normally. Played for about 3 hours, found all the watchtowers and completed a task or two. This was under KSIVA:p:27e2d.
Later in the day went back and attempted to continue with KSIVA:p:c274c @ 2007 local. No joy at all and kept crashing back to games launcher.
Can see frustration looming again among the community. Can a difinative solution to this issue be resolved soon????

Game loads fine, however Paystar 5600 still does not have 4WD available in game even if installed in Garage.

Are they going fix the 2/8 truck bug when u own all of them


im pretty sure awd is a bug, all 4 axle paystars are 8x6 (incl twin steers), so this unique (crane) chassis is 10x6 or 10x8

dont expect 10x10

@Stazco No, the paystar 5600TS in SR was intended to have 10x10 I think, because front axles are not seperated in the xml-file, so 10x8 is not possible. It is just one word in the file of the truck that is wrong. Instead of "torque=none" it should obiusily be "torque=engageable" - then the awd is working just fine once you found the upgrade. So it is not even a bug, just a small mistake... Could not be easier to fix.
As a 10x6 truck that thing is pretty useless in the game, since SR roads are much tougher than the real dirt roads those long trucks drive on.

last edited by bellerophon

@bellerophon said in PTS Update 11/01/2021 (12.1):

No, the paystar 5600TS in SR was intended to have 10x10


SnowRunner Screenshot 2021.01.13 - 10.04.16.jpg


files, ingame pictures, who cares...i hope licensing agreement dont allow fakes...

i use ws twinsteer and enjoy its 8x4 (i know there are 8x8 irl), its a monster!
so 10x6 will be fine too!)

Crash dump after trying to log into - trying to change the video - switching out to password manager and back.

Windows version is 20H2. Core I5, 16GB RAM GTX 980Ti

@Patte352 said in PTS Update 11/01/2021 (12.1):

Can confirm it works as intended!

There is a little missing from that vid, saves may not take ~ and initial.pak needs to be deleted and the new archive extracted ~ notepad worked for me NotePad++ was not saving ????

last edited by gbeeTen

*Nothing has Been FIXED. Do you even play the PTS?? It crashes NO MATTER what you do.

  • The Modio DOES NOT WORK. just keeps loading. And the PTS CRASHES EVERYTIME it is started. There is a whole thread on this and JELLYFOOSH has NOT responded once. WTF..
    *I have PURCHASED EVERYTHING since the first Spintires. I know it's only close to a couple of hundred of dollars. But it is money that I have invested into the franchise, and to get Nothing but nothing from the Dev's.
    *I quote "which should resolve some crash issues and other bugs."
    WTF is "Should" and "Some of"??[Taken from PTS Update 11/01/2021(12.1)] That really sounds like a big snow job from the Dev's.
    *WE Deserve different results , Your update Needs to change the wording to- 'should=will' and 'some of=all of'.. oh, nuts nothing was fixed. At least you were honest .
    *Thank You for taking the time for looking into this matter for me and All the other Snowrunner's that are at the end of their ropes.
    Rufus Johns