I had this problem happen 2 times already in two different coop sessions with two different tasks.

First example is "Only For The Worthy" task at Grainwoods River. As you can see in the clip I am unable to attach winch to the task truck, neither manually or with auto-winch:
After that I tried switching to a different map and back, since sometimes this fixes coop-related issues but it made things worse. The task truck started hovering and acting as if there was no gravity. The steering wheel and a part of suspension was hovering in the air away from the truck. Still couldn't winch the truck:

Second example is "Fixer Upper" task at Smithville Dam. Again can't winch the truck, it has no gravity and there is steering wheel and axle beam hovering in the air with polygons stretching towards the truck (this time I didn't switch map).

Both times I was playing as client. In both cases there was a different player interacting with the trucks before I did. When other player would winch the truck it would teleport back to where it was before I started pushing it and after that I would be able to winch it once, but when I tried to disconnect the winch and connect it again it wouldn't let me. I would have to wait until someone else winches it again.