Issue with texturing my dodge truck (and my others)

@riskywisky, Do you have the textures in a folder named Brute-Suburban?

last edited by Tattoo

@riskywisky said in Issue with texturing my dodge truck (and my others):

I did notice that spun uses something called "Substance Painter". Would that help me?

Substance Painter will not help you with this problem. It will help to make better looking textures, tho.

The a in __d_a means that there is an alpha channel in the texture. For it to work, the alpha channel needs to be all white or close to it. You can look at the glass textures to see how it works. The alpha on the glass textures are a greyish color to show dirt on the windows. If the alpha is all black, you won't see none of the texture.

The uncmp in __d_a_uncmp.tga means un-compressed. It is used so the game uses the full resolution of the texture and not mipmaps. It's what a game does to save on resources. The further you zoom out, the lower the texture resolution to save on memory since it's not close up to see the detail which is where LOD's come in, level of detail. ST or MR don't use LOD's for the vehicles, tho.

last edited by Tattoo

Yes, all of my textures are in that folder, it is just how everything in the code is setup

@riskywisky, Is it like this;

classes
meshes
sounds
textures\trucks\Brute-Suburban\textures.tga

Yes, like so:

<Material
	MeshParts="ANT_001"
	DiffuseMap="trucks/Brute-Suburban/dodge__d.tga"
	TwoSided="True"
/>

Also, what do i need to change here?

<Material
	MeshParts="ANT_001"
	DiffuseMap="trucks/Brute-Suburban/dodge__d.tga"
	TwoSided="True"
/>

What should i change? Anything? Cause running this code must be serving an issue..

@drgonzo1489 said in Issue with texturing my dodge truck (and my others):

The editor breaks the model up by material now so if there's more than one adding the mesh pieces like you did only grabs the first one being 0.

This ^^^
Where you have "ANT_001" with no numbers afterwards, it's applying that texture to ONLY 1 part of your model (part/material 0) so unless your model is one single mesh, you need something like "ANT_001 0, ANT_001 1, ANT_001 2" etc. depending on how many materials are in your model.

last edited by Mexican_420

What do you mean "This"

@riskywisky, Do you still have them as .dds? You might try .tga. I've had some trouble using .dds and seems to work better at .tga.

@mexican_420, Yes, his model is only one mesh so no need for the 0 after the meshpart.

Well, how do I fix this? (i use .tga)

Aslo, mex, ANT_001 is my whole truck mesh 😉 i know what i am doing

last edited by RiskyWisky

@riskywisky said in Issue with texturing my dodge truck (and my others):

Yes, like so:

<Material
MeshParts="ANT_001"
DiffuseMap="trucks/Brute-Suburban/dodge__d.tga"
TwoSided="True"
/>

Also, what do i need to change here?

<Material
MeshParts="ANT_001"
DiffuseMap="trucks/Brute-Suburban/dodge__d.tga"
TwoSided="True"
/>

What should i change? Anything? Cause running this code must be serving an issue..

I was referring to the mod folders. not the code.

Can you zip the images and send em to me. Maybe you did the images wrong.

@riskywisky said in Issue with texturing my dodge truck (and my others):

Well, how do I fix this? (i use .tga)

Aslo, mex, ANT_001 is my whole truck mesh 😉 i know what i am doing

Contradictory much? If you know what you're doing so well, why are you asking for help? 😛

I know what I am doing in terms of the grouping and common sense stuff lol :p

@riskywisky said in Issue with texturing my dodge truck (and my others):

<Material
MeshParts="ANT_001"
DiffuseMap="trucks/Brute-Suburban/dodge__d.tga"
TwoSided="True"
/>

OK, this is what I see. The texture, dodge__d_uncmp.tga, has an alpha channel in it and it's white. That's good but you don't need an alpha channel for the body. The alpha is used for transparent parts like glass. I would remove the alpha channel and just go with the code above. BUT, you also have to rename the texture correctly. So only have the __d.tga on it. Try that and it should work. You don't really need uncmp. You have no detail in the model to need using uncmp, so I'd say remove that.

Let me know how that works for ya. If you don't know how to remove the alpha, let me know and I'll send ya a new one without it.

last edited by Tattoo

Been there, done that. No luck

Have you been clearing your cache folder after every change? You need to remove the mod from the cache folder every time you make a change because it won't get converted again if it's in there already.

try going to AppData\Roaming\SpinTires MudRunner\MeshCache and delete the Suburban file.

@riskywisky, I couldn't get the texture to work either. I dunno man. Can you take a screenshot of the exporter setting? Maybe it's the exporter settings you have selected.

https://drive.google.com/open?id=10eKdGelrjJY7VVCkMKPyjxPvnKDpC_JJ there is my settings for AXE, i also have the kW exporter as well

@riskywisky, That's pretty much what I use BUT I only select the Materials choice when I have more than one texture applied to my mod. I would try to export it again and unselect the Materials. It was something that messed up Mexicans mod. That may just be the problem here. worth a try any way.

I honestly think there is a problem with Max 2018 and the axe exporter because I've been using it for a few years now and never seen this problem.

last edited by Tattoo

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.