testing maps

Hey Guys,

First of all, thanks to all of you for all the content/guides you've created. It makes it all seem possible for noobs like me.

I'm trying my hand at map editor and would love to test it in game, but there seems to be some global issue where a bunch of us (all of us?) can't select the level in proving grounds.

So question is, how are you guys testing your mods? Is there some workaround outside of publishing WIP?

Thanks in advance!

Community Manager

Hi there!

You can upload maps privately to the workshop, so that only you/your steam friends can see the map. This may help with the testing 🙂

@iyagovos had a bunch of problems with it ("failed to load level. out of date" etc.) but finally got it to work by moving the rock models (I think) in conjunction with what @joridiculous suggested (was also having issues with the rock textures not loading). Though I am testing the map through the workshop.

Long story short, not 100% sure what fixed it, but I can test it now!

Thanks to both of you for the help.

FWIW, I think there's a lot of confusion for newbies with all the information out there from pre-workshop support and then post. I haven't even attempted multiplayer yet! Not saying it's anyone's fault (the modders on here are ridiculous 🙂 and literally what brought me to the game), but it seems like there's a lot of trial and error involved that could be mitigated by one true method. Though, I suppose, that also requires all the tools to work properly. Anyway, thanks for the great game.

i have lost the ability to test my maps since i updated the editor, (i waited a couple weeks)..
__i have attempted to load my map the 'old' way and by the method in the newest editor guide. and a couple of unconventional ways. All with the 'broken or...' error.. so I'm at a loss Again.
__the provinging ground option is giving me a 'post a hint' window, not a level selection pane. i will try
Iyagovos' suggestion and publish it as a private view. if it works i'll chime in. thank you all- Rufus

So now there's a new issue. I was making some changes, then published the map again to test. When I went in to the game, I loaded the map (even unsubscribed, then resubscribed) to find that changes hadn't gone through.

So I went back into the editor and loaded the map, and sure enough all the changes were gone. Thinking I must have made an error saving, I cursed myself and got started redoing everything I had done before.

Except that when I hit rebuild terrain, all of my old changes came back. WTH!

And this is where I am now, I rebuild terrain -> Save then close the file. Re-open and back to where I was before this started. Even if I make new changes, it all disappears when I reload the file.

Any thoughts?

I saw something about deleting the file and then reloading it, but I'm worried about deleting the wrong file and losing the work I've already put in.

Nevermind, figured it out. Had to create new mod in the editor and load the old level.

Works for now!

how did you get the 'old' level into a new mod folder.? i have somewhat of the same issue, the map goes thru with no trucks, so i can't test it.. but when i go back to the editor.. the trucks are there. plus there are 6 or 7 mod files in the file tree. all are empty( no prebuild) except for the one i'm working with. Yet the publishing the map SEEMS to of helped, if i could get an active truck on the map. i'm going to whip up a quick map and try that.. -Rufus

@rufus I just imported it like it was an _imported2016 file.

Look at pg. 44 from the official beta guide.

i might just will wipe it all out... don't want to.
__ without having enough PC base knowledge, it's a bitch to organize all of this, so that it works.

__ **The Editor Does Work! __i'm not knocking it at all. I have 530+ hours on it, and can put out some really good maps. (and i still cannot get a handle on the 'management side' of the process) Thank you all, Rufus.

last edited by rufus

@rufus I was worried too, but you don't have to delete anything until you're sure. Just create new mod and then "open file" -> then find the "level_mapname.xml"

It'll create a new .dds and .stg for you and everything should be loaded in. Publish that and you should be good to go.

Worked for me at least 🙂

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.