[Xbox One] Some minor/annoying bugs.

Platform: Xbox One (original "fat" factor)

Version: 3.0.177.24 (At the moment of this post I dont have proper internet for the console. When I can I will update to 3.0.210.1)

Bugs:

  • Campaign: Game is unable to properly end the Campaign: After the credits roll, the game does not play the final Skaven clip and gltiches out of the Skaven Vision screen into the normal Cabal Vision loading screen and stays on what appears to be an infinite loading screen. You can hear Jim and Bob talking as if you were in the main menu.

  • Campaign: Some Character model's heads misplaced: During the final game of the campaign, some of the mutated huge rats (there were three or four at that time) had their heads lower than they should have been.

  • No Fans Cheering Sound FX: after playing a friendly game, going back to the main menu, and then starting another friendly game, that game will be missing the cheering fans sound FX from the coin toss onwards. I tested this several times with the same result. Only restarting Blood Bowl 2 LE restores the sound FX only to happen again on the second game. This never happened during the campaign. Havent tried leagues. [UPDATE] This issue may be side stepped by, after finishing the first friendly game, starting a replay and quiting it. Then starting a second friendly game. I use friendly games in this description since I havent tested this on other modes. I'll leave that to Cyanide.

  • Two skeleton guards occupying the same spot, left side in the main menu. This happens when coming back to the main menu after completing a game.

  • Typo at the results screen: instead of Tournament it reads "Toornament". [UPDATE] Apparently this is how it is spelled because it seems to be a league or something.

  • Kick off "kick" animation glitch: some times the ball isn't properly aligned, by quite a margin, with the character model kicking it. This rarely if ever happened during the campaign mode.

last edited by Darkstar Gekko
  • [Single Player game] After pausing the game, you can still seletct to end your turn by accident even when only up/down A/B should be the only buttons working in that moment.
  • [NEW] Replay did not delete completely: Last night I deleted the one replay I had of a match I had just finished. Today I saw that replay on the Cabal TV (even when I knew there were zero replays there). Started the replay and the game started loading, then Jim starts his game start dialogue and the game crashes. Tried it again and as expected it crashed again. Checked my save file and it is at 710.8KB. Started the game again and just deleted the phantom replay and it didn't reappear this time.

  • UPDATE Found something that may be related to the above replay bug : Just finished a game. Went to see the replays and found two replays for most recent match. But the weren't exactly copies. Both had the correct teams. The first replay was the correct one, with a final score of 1-1 and the correct time stamp. The second replay had a time stamp of nearly fifty minutes earlier (coincidentally this was around the time I had started the match). That fake replay had a score of 0-2. I knew that replay was bogus, so I tried to watch it: loading screen, replay is about to start and for a second it showed the score 0-2 and it said I had conceded the game, then the game crashed. The game made up a replay. I mean, wtf?

  • Vampire team typo: the annals for the vampire team with a 1000TV has two M's that I think shouldn't be there.
last edited by Darkstar Gekko
  • Missing button prompts in the main (and other modes) menu screen: First time I've seen this happen. Just noticed that the button prompts at the bottom of the screen in the Main Menu, Cabal TV, and Friendly Match were missing. For example: while choosing teams in Friendly Match, the B, Y, and A prompts were missing (the top left "Press A to join" one was still there). Pressing a button, if you know what it does, still works. But if, while in the Cabal TV menu, you dont know that X deletes a replay (and without the common "are you sure" option in many other games), you can accidentally loose one.

  • [UPDATE] This may be related to the bug above. The LT/RT prompts that lets you change formations during team set up, right before the kick-off, were not there. Furthermore, pressing either LT or RT had no effect. I believe I had nine or ten players in the pitch when this happened. I could still move the players manually.

last edited by Darkstar Gekko
  • Bombardier character didn't animate nor move when pushed by the opponent, leaving both character models in the same square. The game still knew where the bombardier should be. This may or may not be related/caused by the next one below:

  • Bombardier action time (Probably not a bug but a problem nonetheless) How come the game takes so long to resolve the Bombardier? A pitch invasion is resolved almost immediately. I am no programmer, but something is clearly bad, or unnecessarily being calculated, in this situation.

  • [New/Update] Opposing team's Bombardier could not be highlighted: After the opposing AI team's Bombardier performed his bomb move I noticed it didnt have the circle icon on that player. I tried to highlight the bombardier during my turn but couldn't.

  • [Observation] I think all of the dice rolls for the bomb throw should be in the dice log, but they aren't.

last edited by Darkstar Gekko
  • Double blitz in the same turn: This was versus a wood elf AI team during a friendly match. The first war dancer wood elf attempts a blitz action leaping into a cage. He misses the landing, rerolls and succeds but does not block my player. The next wood player the AI moves also does a blitz action, even though he was adjacent to my player, and blocks. Both wood elves now have the blitz icon.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.