Vampyr (PS4) Blackmail in Whitechapel quest bug, can't continue story, got stuck

@joeltopia Thanks for letting me know, I'll pass this along to the team

Was the patch meant to fix the issue in a save file where you've already encountered the bug or do you have to restart the game because the patch only prevents the bug happening in the future?

Reason I'm asking is because I've got the latest patch I believe (Xbox One Version which said it was updated on 27/09) and the save game which had the problem still isn't fixed. If I knock on the door, I'm told, can't enter, nobodies home.

There's no red circle on the ground anymore to start the cutscene as I've already seen it but had the issue of Nurse Crane being missing and the game was saved after this point. Now Darius is just standing facing the door where you overheard/saw him talking to nurse crane. Also the game is still informing me to Investigate Darius Petrescu's actions.

So is this save file corrupt and I need to restart the game or was the patch meant to fix the issue and let me continue on from here?

@desertwolf1981 I believe the fix is supposed to have been retroactive, but I'll double check that for you and update this post as soon as I have a response.

Yea... I also still have this issue myself and got very irritated to see the update did nothing. So decided to restart completely hopefully it doesn't happen again, but my hopes aren't that high anymore.

@iyagovos Having the same problem as desert wolf no red circle bought the game was having fun and now just disappointed hoping y'all can fix this soon because I paid for your product my dude.

Hello, I recently bought this game and I’ve been really looking forward to it for awhile, so it really pains me to say I’m stuck on this mission too. I play on Xbox.

It would appear that my issue is, well, unique.

After talking to Darius, the game instructed me to “investigate his actions.” So I turned on my vision to see what he was up to and I followed him all the way into the back garden where I ran into the gate. Darius is still standing there by the door, with the “eavesdropping” icon over him, but no blood stain in sight to activate to continue the quest. This happened the very first time I tried to speak to him, but the bloodstain didn’t load at all. So I restarted my game. That didn’t work. So I restarted my Xbox. And that didn’t work either. So now I’m stuck, with no possible way forward, 10 hours into my play through.

Any chance you folks could help me out as well? I really, really don’t want to play through everything again, especially after completing numerous investigations. This is honestly a massive let down. I really hope you guys can help.

@willt01 Hey there,

You started playing after the most recent update, correct? I'll pass this along to the dev team and get them to continue investigating a fix.

Is this bug going to be fixed soon? I can't continue the game because of it. Same as everyone else. Cut scene didn't show the nurse and now Petrescu is just standing by the door where she was supposed to be. Mission tells me to investigate him. I don't know what do and it getting fairly disappointing. Especially since this has been a game I've been anticipating for some time now. Please fix this immediately I'd love to continue the game.

Any fixes to be released soon? This bug has been reported in June and is still not fixed. Can’t continue the game.

Hello everyone, i'm on my second playthrough of this game, after the difficulty updates i decided to play it once more and to my surprise this bug occurred. I'm on Xbox One and i have the same exact problem. Dorothy Crane invisible and Darius standing in front of the door doing nothing. Is there any kind of solution to this? Any news?

I've recently purchased this game and have come across this exact same bug, reading back that this issue has been left unresolved for months is kind of disheartening I was thoroughly enjoying the game up to this point, now I just can't even find the energy to play it.

@iyagovos I just started playing a few days ago & sadly encountered this bug 😞
Loved this game but I've now finished all side quests and can't go on until the bug is resolved... Restarting & playing from the beginning is not an options for me. Any news of when a fix may be available?
Please help

Mass refund operation underway?

@missazane We're still looking into it, but I don't have any news on when a fix will be available right now

Add more people to having this issue and wanting 60$ back after months of not being able to play

I want to add my experience as it differs a little from the OP's video.

I'm on PC and what I did was talk to Darius. I saw him walking away and noticed that he had bronchitis. I immediately went to the nearby safehouse and made a medicine for bronchitis.
When I walked back, Darius was standing at the place where he's supposed to be (according to some youtube videos I watched) but I don't get a red swirly prompt to eavesdrop at the metal gate.

Hope this is somewhat helpful for the Devs in figuring out this glitch.

I also encountered the issue on PC, the red pool doesn't appear. I bought the game last week, so well past the difficulty patch. I can provide a save if one is still needed. The game is amazing but this bug is infuriating.

Update: I saw in another reply that standing still near the gate for several minutes could solve the issue. IIt worked for me. I stood there for maybe 5 minutes before the red pool appeared and I was able to proceed in the game.

last edited by Mae55

@Iyagovos Encountering the same issue here. When I got within I believe 50m of the initial objective, i.e. speaking to Petrescu at the door, I was forced to a walk and kept that way for roughly 20m. After speaking with him at the door I proceeded to the gate and eavesdropped on the conversation, Nurse Crane was invisible but spoke and she had subtitles. After the cutscene completed Petrescu continued to stand at the door and I was show no objective, thought the quest title remained on the right side of the screen. After this occured I was unable to speak with any Citizens. I reloaded the save and the "Investigate Darius Petrescu's actions" objective appeared once again, but Petrescu was still standing by the door at which he converses with Nurse Crane and the blood pool was nonexistent. I was able to speak with the woman selling the Cordial, but again unable to proceed. I bought this game a few days ago for Xbox One and I must say I'm very disappointed. I have been following this game since a year before release and I was extremely excited to finally be able to play.

I've come up with the same issue as well. Bought the game on PS4 last week and can't continue through the main story as can't progress on the 'Investigate Darius' part of the mission. He just stands at the door. Looked up the mission on YouTube and I don't get the red on the floor that helps you click to focus on him and no option to listen in. Please sort the issue. Was really enjoying the game till now 😞

@dapino This is the same issue I'm currently experiencing. No red swirly on the floor so unable to eavesdrop. Can't continue game