Vampyr (PS4) Blackmail in Whitechapel quest bug, can't continue story, got stuck


I had this problem as well. I think I read earlier in this thread (or some other site) that if you stand at the gate where you see Darius then the red swirl will eventually appear. I tried this a few minutes ago and it worked. Just stand there. Don't move. It may take several minutes. It eventually appeared for me and I was able to continue.

Hope this helps.

@razzer I can confirm what you are saying as it worked for me on PC after standing at the gate for a few seconds only.

last edited by Silver145

@Razzer Does nothing for me, just automatically pauses after a while.

It is January 24, 2019 and this just happened to me, crazy to think that it has been this long and have not fix it. This happen on Xbox one, please fix this!!!

My name is ARRlS GAMlNG on Xbox one and on vampyr my game bugged when I tried to skip the cutscene when Darious talked to Dorothy and now he is stuck in the door and won’t move even though I have all the hints for him to let me into the house to see Dorothy. You talked about trying to fix this bug with another person on June 7, 2018 and still has not been fixed. Please have your team look at this again!

Bug is still quite active on PC.
Just bought the game this last week, just on my first playthrough.
The eavesdrop point does not exist.
I'm about to try a second save file...

EDIT: Second run worked, although the eavesdropping point did flicker in and out of existence as I was trying to stand on it.

last edited by Niekitty

Bug still active on Xbox.
Like almost everyone else, I came here because could not get senses to activate. Read the "fix" and after trying every possible location and distance near the gate (the one that does NOT open, people. No icon) senses popped up on the far right, about 2 steps back, and after I was locked on to him, and hit select to bring up his details/hints and backed out. That worked. I watched the scene, Nurse was there, and tried to move on...

Unfortunately, my game crashed when loading from the scene back in to the game. I came back, and had the bug where you cant run and/or talk to people (which is fixed 99% of the time by reloading, folks). I was between Darius sense location and the vendors so hit people up on the way. So i relogged again, that was fixed. NOW, I tried to proceed with next part of quest, and Darius is still sitting right where he was, against the door, where you perform the sense thing on him and watch the vid. But now there is no sense thing, because it's done, and I'm supposed to "investigate his actions" but, welp, I can't.

So there's fix for the blood sense reiterated, a fix for the bug where you can't interact with people... AND still A BUG for very next step of the MAIN QUESTLINE.

Can I please get a respomse, just acknowledging this has been seen, if nothing else?... A solution would be grand though... Thanks in advance.

30 August 2019 and i have the same problem on the Xbox One... Any fix? I try everything...

Thanks for sharing..................

Guess what.... I just started playing this game on the Xbox one because it’s on the game pass. And I was really enjoying it.. UNtIlL this happened to me, this girl was invisible and now I can’t talk to anyone. I can’t imagine how you guys feel if you payed money for it. 2019 !!!

Yeah, so... Same here. My save is super busted because of this glitch. I'm playing on Xbox one. Super unfortunate.

Hello, I just so recently purchased vampyr on PlayStation store and the blackmail in whitechapel bug, the one with dorothy crane speaking to darius about someone at the door. Yeah, I got an invisible dorothy, and darius is stuck at the door, and I was wondering.... It is 2020, explain to me, why is this still a thing, I have already spent too much time on side quests leveling up, cause I don't want to kill any civilians and this is what I get for buying the "dlc" as well. Like game developers I get that it is hard sometimes to fix bugs and it takes time.. But what in the actual ****

@Netheos hello, I'm a salty gamer, it is 2020 the bug still exist
I couldn't wait to play the game but right now, I'm thinking on burning the disc of the game, but wait i can't cause I bought it online, oh and also can't get a refund oh joy

Hi guys, i play on PS4 and i've found the petrescu bug and also one in barret's box quest' (finding the box doesnt change the quest log). I managed throught the first one locking petrescu and making a crazy on/off with vampire senses, can't do nothing for the second bug. Is there any PS4 bug list? There will be some fixing patch?