Joined
Last Online
Recent Posts
posted in MudRunner - General Discussion read more

not into the idea of making this a grind game,just saying.

posted in MudRunner - General Discussion read more

@unster said in My thoughts regarding American Wilds.:

@stazco
Yeah I'm not buying that either. The picture even looks wrong. It's a road truck stuck in mud. It probably helps that you have the back loaded, but still I bet that truck is barely moving if at all.

i have towed the skidder 8400 with the LTL 9000 through the swamp as did my buddy following me and he was using the freightliner and towing the skidder aswell.

i also had a load of short logs on the LTL 9000 and it was just crusing through the mudd.

posted in MudRunner - General Discussion read more

i dont see the problem with the controls,about 5 mins and i was good to go

posted in MudRunner - General Discussion read more

the k8400 skidder can load short logs and long logs, its not that hard.

posted in MudRunner - General Discussion read more

i dont hear any sound when useing the crane, only sound i hear is the engine running,

posted in MudRunner - General Discussion read more

just use the joy stick to move the cam to the other side of the truck, thats what i do.

posted in MudRunner - General Discussion read more

they have the short log bed, that goes on the back of the truck.

posted in MudRunner - General Discussion read more

me and bud just did this , we towed the 8400 skidder with the LTL and freightliner.

i was in the LTL and he was in the freightliner,

we went through swamp on grizzly creek and logmore, and had no problem,

also i put the short log cart on the LTL and put the B130 in the back with the fuel barrels in the back of the B130 and the LTL went through the mud like it was nothing.

as for the k8400 skidder being not able to load trucks, its easy, with shorts and long logs,
just turn the logs straight with the skidder and back it in to the trailer,

as for the WS i dont think its that good, just seems slow and underpowered

posted in MudRunner - General Discussion read more

the 3 times it happen to me, i was using the LTL ford,

first time i driving down the road in 5th gear and the (lost load) popped up on the screen and i looked backed and the logs were laying on the road,

posted in MudRunner - General Discussion read more

@iyagovos they are packed and long log loads


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.