Joined
Last Online
Recent Posts
posted in World War Z - Technical Feedback read more

Thankfully I'm Australian based and protected by the ACCC. I emailed Epic Games explaining the problem and that the game had a 'major problem'. Despite speaking with developers. Despite posting in the forums. Despite problem solving software and hardware. Despite waiting patiently for the 'magic patch'. Co-Operative play (for me) never worked in this game. Which is a real pity because it is a fun game to play, but without functional co-op play that fun is short lived.

I was given a full refund within 48 hours.

While this wont help my friends in the USA (your consumer rights aren't as generous), those in Australia or Europe may want to explore this avenue if you're at the end of your tether.

posted in World War Z - Technical Feedback read more

Exact same problem. I have yet to play a game co-op with a friend since purchase. Very disappointing.

posted in World War Z - Technical Feedback read more

I'm unable to play Online at all. Friends or no friends. The game moves from lobby to black screen (with the writing at the bottom) and never reaches the loading screen. Meanwhile I'm playing a dozen other online games just fine.

Not sure what feels more 'early access' here, World War Z or the Epic Games client.

posted in World War Z - Technical Feedback read more

I purchased the game on the 23rd of April (Australian based).
I spent the entirety of my time that day playing the game in Offline Co-Op. Quite enjoyable.
On the 24th I attempted to play the game online with a friend.
After leaving the lobby everyone else on the team receives a loading screen and then enters the game.
I do not.
I'm left with a black screen and the text and the bottom that includes date, time, server information. The clock keeps ticking so the game doesn't appear to have hung. This screen does not change. I am unable to leave this screen.
If I terminate the program it then ends the game for the other players, dumping them back to the menu.
I have tried playing the game without friends, just a random public game, same problem.
I have tried playing multiplayer, it finds other players but then simply stalls at the Starting Game.

Something with this game, and I'm not sure what, is getting stuck at the point of joining an online game.

I have checked my Firewall settings and fiddled as best I can. I've allowed both the Epic Games Launcher and World War Z to pass through the Windows Firewall. I've even tried setting my router to DMZ. Nothing helps. Conversely I'm playing plenty of other game online without any problems.

I'm confident at this stage it's a problem with either the Epic Games platform (which I've not used before) or the game.

Unfortunately this particular problem doesn't appear common, so I might end up being one of those people caught out.

Any advice or help you could offer would be greatly appreciated, as I believe the game (while fun in offline mode) will be a heck of a lot of fun with friends.

PC Specs
CPU: Intel i7-6700k @ 4.0Ghz
MOBO: Asus Maximus VIII Hero LGA1151
VIDEO: MSI GeForce GTX 1070 Gaming (8GB)
RAM: Corsair Vengeance 4x8GB (32GB) DDR 2133
MONITOR: Samsung 27” Curved 1080p 144Hz 1ms

UPDATE: The recent maintenance (25/04/2019) appears to have fixed this problem. I was able to play online with a pick-up group no problem (beyond latency from being in Australia).