Joined
Last Online
Recent Posts
posted in MudRunner - General Discussion read more

Oh! Okay, I wasn't sure if there was an option to easily place the smaller truck onto the trailer like how you would attach a winch. K700 or terrain, I'll have to try that out. Thanks!

posted in MudRunner - General Discussion read more

As someone who is still new to Spintires as a whole, can anyone explain how you are able to load one vehicle onto the back of another? Like with the challenge called Delivery Mission with the A-class sitting on the back of the trailer. I've seen some trucks on the workshop which have ramp trailers but I've never figured out how to do this with the game's default vehicles...

As for the original post, I've witnessed some situations where adding weight onto the rear wheels definitely makes a difference in traction. If you're towing a trailer without any extra weight on the drive wheels then you will struggle more in finding grip, as well.

When doing the challenge to deliver only small logs and to only use the B-66 I found that while empty I had to frequently use the winch to get myself back to the log station but after loading it up it would make the trip to the mill without any assistance. Similarly with the C-65115 that doesn't have diff lock or AWD, it would get stuck everywhere until I put a fuel trailer on the back! Then it only got stuck half of the time.

posted in MudRunner - Technical Support read more

That's great to hear, thank you Iyagovos!

posted in MudRunner - Technical Support read more

I've only played multiplayer with friends but between the four of us we have all been getting this .STG error on every attempt to play together. Trying to get everyone together into a game, even with no mods being installed, eats up a lot of time and leads to a lot of frustration.

We've tried all sorts of tricks. Verified game file integrity through Steam. Host launching then players connecting directly through Steam. Having different people host (best success here when the host is someone with a poor connection.) Joining the game while leaving the Steam overlay active. We've tried all starting out in the game lobby at the same time, we've tried joining after the game has started.

Typically with four of us only the host and one other player makes it in right from the start, the other two will have to try joining many times before it works. With just three players total it's very common for only the host to make it in right away.

Even with just two people, the host and one other player, it can take multiple tries to connect. I'm really surprised that this issue doesn't seem to be getting more attention, it's been terrible! We want to play this together and we simply are not able to.


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.