Joined
Last Online
Recent Posts
posted in BFG:A2 - Technical Feedback read more

Hi, thanks its been reported to the devs !

posted in BFG:A2 - Technical Feedback read more

Hi, thanks for the feedback, the outline around the ships when you over your mouse on it is normal even when f10 is pressed. For the base of the ships, you can use the new Filters feature in the upper left side of the screen to ensure it's not coming back (uncheck all should work). Hope this helps !

posted in BFG:A2 - Technical Feedback read more

Hi, the Invite button on campaign mode should work, some softwares are known to prevent the steam overlay to show up. Since the Invite coop button opens the steam overlay, you would see nothing happening when clicking the button in game in this case. Try to press shift-tab while in game to see if the steam overlay comes up or not. If it does not come up, it means that one of your running software in the background is preventing the steam overlay to work properly and you'll need to figure out wich one. Hope this helps !

posted in BFG:A2 - Technical Feedback read more

Hi, with the new reinforcement system you need to select the shipcard of the ships in reinforcement then make a right click somewhere on the map to deploy them, i hope this helps !

posted in BFG:A2 - Technical Feedback read more

Hi, yes this is a known issue and the devs are aware of it ! Thanks for the report !

posted in BFG:A2 - Technical Feedback read more

Hi, it's a known issue and the devs are working on it. In the mean time there is a workaround if you want to finish the mission you just need to press the "play" button beneath the mini-map to resume the game, this should launch the cinematic and finish your campaign. Hope this helps !

posted in BFG:A2 - Technical Feedback read more

Hi, yes this was a known issue that's been fixed but unfortunately the fix is not retroactive so you will have to get rid of this escort ship or not use it anymore (if you don't want to). You will not encounter this bug on any new escort ships you made. Hope this helps !

posted in BFG:A2 - Technical Feedback read more

From what i can see on the benchmarks, the 760m is below the 660 (wich is the minimal required GPU to run the game) so it seems you might indeed be a little short with your GPU to run the game unfortunately

posted in BFG:A2 - Technical Feedback read more

Hi, we had some reports about crashes when selecting a fleet before and those player had GPUs that did not meet the minimal requirements for the game, could you send us a DxDiag at support@focus-home.com (with a link to this thread in the mail so that we can know it comes from you) ?

posted in BFG:A2 - Technical Feedback read more

Hi, yes it's a known issue and the devs are aware. Thanks for your report !


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.