Joined
Last Online
Recent Posts
posted in BFG:A2 - Technical Feedback read more

@mojo50002 Thank you for these. Could you please also tell us when exactly it crashes?

posted in Insurgency - General Discussion read more

Hey there @Max80
Thanks for the suggestion, we have passed this on to the dev team! 🙂

posted in BFG:A2 - Technical Feedback read more

@marwang25
Thanks for the details! I'm not sure I completely understand everything though - you say it freezes and stops responding every time you try to enter a battle. Is this during the loading screen or after? Also, if you can't enter a battle, how does the battle run smoothly?

posted in BFG:A2 - Technical Feedback read more

Hey @gfl

Unfortunately I can't give you an estimate right now, but I can assure you the team is aware of it, and when it's fixed it will be clearly stated in the log. 🙂

posted in BFG:A2 - Technical Feedback read more

Heyt @goldstrike

Are you still having this issue after the April 1st hotfix?
If you could provide any more details regarding where and when exactly you crash, that would be very helpful! Thanks. 🙂

posted in BFG:A2 - Technical Feedback read more

Hey @Battlefiend

Are you still having this issue after the April 1st hotfix?
If you could provide any more details regarding where and when exactly you crash, that would be very helpful! Thanks. 🙂

posted in BFG:A2 - Technical Feedback read more

Hey @marwang25

Are you still having this issue after the April 1st hotfix?
If you could provide any more details regarding where and when exactly you crash, that would be very helpful! Thanks. 🙂

posted in BFG:A2 - Technical Feedback read more

Hey there,

Are you sure you haven't set Steam to offline mode?

If not, please make sure your firewall isn't blocking the game.

Hope this helps!

posted in BFG:A2 - Technical Feedback read more

Hey @Mojo50002
Could you please provide a crash log and DxDiag to help us identify the issue? A screenshot of the error message would also be very helpful. Thanks!

posted in BFG:A2 - Technical Feedback read more

Hey @Vixie
Thanks for reporting this, it has been passed on to the dev team!


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.