Joined
Last Online
Recent Posts
posted in Insurgency - Technical Feedback read more

I composed a ticket about 2 weeks ago about the issue on servers showing a black screen when loading into them in multiplayer in both casual PvP and AI enemies. Seems it didn't get through so I'll restate because this issue is game breaking. When loading into a casual PvP or AI enemy server, the screen will sometimes go black and stay black, causing a Alt-F4 restart to get back into the main menu. This is a server issue due to many of my friends showing the same issue with better computer systems than mine. This has been an issue for over a month now and is most likely due to lack of dedicated servers or official servers. Is anyone else showing this issue?

My specs:
Radeon Software Version - 18.12.3
Radeon Software Edition - Adrenalin 2019
Graphics Chipset - Radeon RX 580 Series
Memory Size - 4096 MB
Memory Type - GDDR5
Core Clock - 1366 MHz
Windows Version - Windows 10 (64 bit)
System Memory - 8 GB
CPU Type - Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz

posted in Insurgency - Technical Feedback read more

My specs:
Radeon Software Version - 18.12.2
Radeon Software Edition - Adrenalin 2019
Graphics Chipset - Radeon RX 580 Series
Memory Size - 4096 MB
Memory Type - GDDR5
Core Clock - 1366 MHz
Windows Version - Windows 10 (64 bit)
System Memory - 8 GB
CPU Type - Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz

When loading into multiplayer servers, the game will often go from the play screen to a black screen with the music still playing, when it should go to the pregame class selection and map screen, I have to alt-f4 to close and restart. This happens only on multiplayer servers as local play is fine. I've seen in multiple other posts on other forums that this is an issue for others as well. I have the game open in windows borderless and my antivirus has exceptions for insurgency, my PC and drivers are up to date. I've tried running as admin as well to no avail.