Joined
Last Online
Recent Posts
posted in Insurgency - Technical Feedback read more

After 1.2 Update the Beta Exclusive tattoo does not appear in my Character Loadout Inventory. But i do still have Bug Hunter dlc in Steam Library. I made this post to make sure/report that the item got removed/redesigned or missing within and does this effects to everyone else.

posted in Insurgency - Technical Feedback read more

@firstcommand Do you have Texture Streaming Pool on High? I see that the game is eating all of your Vram. Try to set it to Low

posted in Insurgency - Technical Feedback read more

@rpgdodger It's rather to be a performance bug effecting some specific system. But i did tried all settings and the result is still the same with gpu usage droping

posted in Insurgency - Technical Feedback read more

My computer specs (laptop):
CPU: I7-8750H 6 cores 2.2Ghz base clock, 4.1 Ghz boost clock (3.9Ghz on 6 cores) 12 threads 9mb cache with Hyper-Threading on
RAM: 8Gb DDR4 2666 Mhz
GPU: GTX 1050 but i always overclock it
HDD/SSD: 1TB WD with 400GB free/ 128GB Kingston m.2 ssd with 300-470 Mb/s read/write speed with having 39gb free (game is installed in ssd)
Note: My computer have a very good heatsink with cpu always around 70 degrees Celsius and gpu is around 60. The Laptop model is MSI GL63 8RC
After the 1.1.4 Hotfix my in-game performance has been dropped to unplayable, it even worst than back in Beta. Last 1.1.4 patch (before the hotfix i got the best performance ever with 65-80 fps with not stuttering and smoothly) before the 1.1.4 patch my game is decent with the same fps average but there are some fps drops and stuttering while using 4x scopes but not much. Now the game is always having hiccups and stutters with average of 55-65 fps. I have noticed that gpu usage is always dropping and to 60-70% a lot even while fps is at 50 fps. When as last patch before the Hotfix i got a solid 95-99% gpu usage. Cpu usage is always around 30-40% as normal. I did tried to delete the config files and reinstall the game but it's still the same and I'm sure that my gpu and cpu is at max performance as i tried others heavy games and my gpu usage is always solid 99% usage. Hope you guys can figure out the problems with the game and keep up the good work!

posted in Insurgency - Technical Feedback read more

As i live in Asia so i have to play in Asia server. But around 95% at the time i always in with Chinese or Korean players, which is they can't speak English. They always use their native language in voice chat and in text chat, they don't understand what i said in English and replying to me in their language. Rarely i'll meet English speaking players. About SEA server, as i know there are a lot of SEA players in Sandstorm, and we're all use English to communicate to each other. So the main topic of this post is to add more region in Asia as Asia server is full of non-English speaker.