Joined
Last Online
Recent Posts
posted in Insurgency - Technical Feedback read more

For me too and I sent my logs during beta.

posted in Insurgency - Technical Feedback read more

If you found a good server and cool guys to play with and don't remember the name of the server, you will never find back there. This should be basic stuff for server browser.

posted in Insurgency - Technical Feedback read more

I noticed this too. Bots can spawn inside ceiling and kill all players without been seen very well.

posted in Insurgency - General Discussion read more

I have had this same problem from beta 2. Something went wrong after beta 1 on server side. I'm playing EU servers too.

posted in Insurgency - Technical Feedback read more

You can play on dedicated servers without any lost connection issues. You don't get any EXP, it sucks but at least you can play.

posted in Insurgency - General Discussion read more

I have the same problem. You can play on dedicated servers without lost connection problems, but you don't get any experience points.

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Yes, for me and many others.
Match may start with full team and soon there is no one there anymore.

Someone infront of me disconnects and this happens all the time:
https://clips.twitch.tv/ColorfulShyLadiesSoonerLater

This is when it's happening to me:
https://clips.twitch.tv/AnimatedVictoriousRavenPanicVis

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Try custom servers, I don't get lost connection there. This is a serious problem and they will see it at free beta when more people try the game. In my area there are many with this problem and the devs are not going to fix it until there are more reporting about this.
If some big streamer is going to get lost connections while sreaming, that would probably make them look in to this.

Edit: build number CL72914.
The lost connection problems started when beta 2 came.


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.