Joined
Last Online
Recent Posts
posted in SHD - Technical Support read more

@sgt-snoke-em No way, dude! That is awesome! I literally just finished downloading the Enhanced Edition after formerly rage-quitting and rage-uninstalling. I am really stoked to give it another try now. I'll let you know how it goes!

posted in SHD - Technical Support read more

Netheos, hello!

Anyword on the random framerate drops making the game unplayable?

posted in SHD - General Discussion read more

@sgt-snoke-em said in Focus Interactive goes Heretic:

@jb0809 said in Focus Interactive goes Heretic:

For focus to actually earn the consumers' trust back they need to actually say something of value and give us actual updates. They also need to tell us an actual date, not a quarter or "early", and actually meet that date. Telling us you can't update us while simultaneously giving no context hardly does anything but irritate more people

While a hard street date would be nice, personally I'd just appreciate something like...
"yes there is a delay, we apologize try back q1 2018, because..... yada yada yada, we had issues with performance/coding/whatever, bla bla bla we'll be on it"

Or better yet... "To all customers, we are now allowing refunds!"

^^^ YEP. This is a joke.

posted in SHD - Technical Support read more

Seriously, this is by far the most pressing issue devs need to be focused on.

posted in SHD - Technical Support read more

I am glad that this problem is being addressed. I just wanted to come and say that I played the game for the first time today and experienced tremendous lag in single player when swarmed by genestealer hordes. Framerate just plummeted.

posted in SHD - Technical Support read more

I managed to correct this problem on my own.

A new problem has emerged - massive drop in framerate when battles start.

posted in SHD - Technical Support read more

I resolved this issue on my own. Even though my computer was telling me I had the latest drivers installed, a quick peak through the actual Radeon website showed me a newer driver available for my card. Once installed, I had no more issues with that.

Only now, whenever I am in combat, my FPS drops like a mother fucker.

posted in SHD - Technical Support read more

This is not giving me hope that I will have an answer or a fix... probably going to have to get a refund. That really, really sucks.

posted in SHD - Technical Support read more

Re: Pink/Purple screen after initial splash screen

After the initial loading screen with the sword and cog, the screen goes completely corrupted with blue/pink/purple colors. I cannot access or see anything other than vague shapes.

I am running a Raedon 7970m graphics card with up to date drivers.

SEND HELP.


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.