Best posts made by pooza
posted in Fear The Wolves read more

Hello.
Well, another weekend and still same error as week ago: "invalid version. Client update needed".
What can I do with this ? i want to update client manually, but i can't find that option...

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.