Joined
Last Online
Recent Posts
posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

my guns are always missing when I first spawn lol takes 5 mins sometimes for them to appear

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Dosnt seem to have changed very much to me, when I click auto in graphics option it sets everything to very high/high and fps drops into single digits make the game unplayable!

Still get best results by custom doing the options but still not a great improvement 😞 sometimes its playable and sometimes not with terrible freezes and stutters even when getting ok fps

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Happens to me sometimes as well, after I die it counts down time until re spawn, then dosnt spawn me and im sat there with it counting down again lol

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Ahh as longs as its just because its beta then that's ok, I just thought the server browser list was live already

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

I have been more worried about the performance on the whole so haven't mentioned this,but, when I go to browse the servers nothing comes up? don't tell me I need to upgrade to a ssd just to play this game properly? as every other game works fine, will this ever be sorted?

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

@musicnote said in Game is unplayable again!!!!:

Have you tried disabling hyperthreading? That seemed to work for me. I got a huge fps boost from 20-30 fps with dips to 1 and frequent freezes to buttery smooth 80 FPS. It was unbelievable, like a whole new game.

im only running a i3 6320 so only have 2 actual cores with 4 threads, think it will be worse for me if I disabled the hyperthreading? don't know how to do it anyway lol

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Things were looking up, tried to play just now and for some reason its a freeze fest again? im getting MASSIVE fps drops from 60/80fps down to 5 fps! yesterday it was smooth and played great, today for what seems like no reason at all, its a freeze fest again!

Whats changed? anyone else find performance seems to have gone today?

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

It is now unplayable for me as well again 😞 was running great all day yesterday but now getting drops from 80fps down to 5fps! game is a freeze fest again for me, what the hell has happened?

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

@feuerholz said in performance after latest patch (06/09/18):

Would you mind posting all your settings?

Oh and does anybody know what exactly the texture streaming pool size is doing?

As longs as you lower the texture pool and the 3 shadow options below it, have smoothing off and uncapped fps it should run quite good, I have the normal shadow option on low, nearly everything else is on medium, I will try to post it all up later.

Not sure what the texture pool is but lowering it (along with shadows) makes a massive difference!


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.