Joined
Last Online
Recent Posts
posted in World War Z - Technical Feedback read more

I had the same problem. You have to equip the normal version of the guns, not the gold. Close the game & restart it, then you should get XP for the advanced smg & assault rifle.

posted in World War Z - Technical Feedback read more

I posted somewhere else, under known issues. Incase that was the wrong place i'll try here as well. The AI Bots have been glitching, they wont move once their health gets real low, like around 5%. Doesnt matter If i heal them, let them die & respawn, or pass a checkpoint that drags them to the group. They will not take another step for the rest of the mission. The bots also will not come to help you if you get pinned by a lurker/creeper whatever theyre called during certain swarm defense stages. I was defending Greengold's house in Jerusalem , ran outside to get a screamer, got pinned by that thing, i could see everyone on team just standing in the house, until I died, then One bot would come to revive me, get pinned by zombie,no one would budge until they died, by then i bled out and fail mission because i was playing solo. Those have both happened to me multiple times.

posted in World War Z read more

I forgot to mention Im on a ps4. But i just had the bot glitch happen again. It seems like once they get really low on health, like around 5% thats it, theyre done, they wont move again the rest of the mission. Doesnt matter if i heal them, let them die & respawn, doesnt matter. I even passed a checkpoint & it will pull them to you, but they wont take another step.

posted in World War Z read more

Ive been playing offline with bots mostly, to avoid all the current issues. I noticed today the AI bots wont revive me during a swarm, in jerusalem defending Greengold's house, i went out to get a screamer, a lurker jumped on me, none of my team would move, until i died, then when help came it was 1 bot, lurker got them, no one would move until they died, by then i bled out and mission failed because i was solo. It happened a second time, but i cant remember where i was. Ive also had one Bot just stop, wont move. Even if i let them die, they respawn & wont move, for the rest of the mission. Thats happened twice today. First time I saw those problems was today.

posted in World War Z - General Discussion read more

I'm having the same problem on ps4. I have the pistol maxxed out already. But assault rifle & smg gain no XP ever. I have tried using regular (not gold) versions as well.


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.