Joined
Last Online
Recent Posts
posted in Insurgency - Technical Feedback read more

Bottom right -> "Apply changes" button

posted in Insurgency - Technical Feedback read more

It did this until the next time I launched the game. Then, it showed the correct 4/10. UI bug.

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

This is fixed in the latest update it appears.

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

I will check again with the latest update.

The problem is that my gun is not pre-loaded with another round when using a light carrier.

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Happens at caches, too. I have to switch to nade launcher, tap F and I'm good to go.

Edit: only happens for Light Carrier

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

I played on a server for a while. During map voting, I tabbed my game down, and when I brought it back up, a message said something about the server shutting down. I pressed Enter, and I was back at the main menu. I could not click anything, and the keybindings did nothing. I had to Alt+F4 it.

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

After death, I spectated a teammate, who had an M870 I believe. When he reloaded, the animation did not stop, even as he fired the weapon. In 3rd person, the animations are correct. The animation fixes when the player switches weapons and presumably when you re-enter spectate.

posted in Insurgency: Sandstorm Pre-Order Beta - Technical Feedback read more

Ping shouldn't really matter... what are your system specs?


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.