Joined
Last Online
Recent Posts
posted in Insurgency - Technical Feedback read more

@potato-rage Same here although I have another issue where I can't switch to a male security force. I'm forever stuck as a female. Any idea what could be the issue?

posted in Insurgency - Technical Feedback read more

This absolutely fixed the issues I had! Thank you! Although I did experience in a pretty good fps drop. I was hovering around 130fps on my 8600k and gtx 1060 but now im around 90fps. Nothing that affects me but just a heads up. Thank you for the input!

posted in Insurgency - Technical Feedback read more

I made a post recently about odd hand textures and positioning and just want to follow up with more issues that are visible during game play and really does take me out of the moment of a firefight0_1554737821181_Insurgency Sandstorm Screenshot 2019.04.03 - 21.05.03.69 (2).png

posted in Insurgency - Technical Feedback read more

i have the exact same glitch ever since i first downloaded the game a few months ago. Do you also have a weird glitch when viewing other players hands? like their fingers are sticking straight out? View my last post to fully understand what im saying lol

posted in Insurgency - General Discussion read more

@miki1911 i wouldn't hold my breath for a release this year. It's still wicked buggy on the pc and the dev team needs alot of time for refinement and polishing first

posted in Insurgency - Technical Feedback read more

@b4ndo it was funny at first but every character model i see has this insane amount of collision

posted in Insurgency - Technical Feedback read more

@chaton thanks for the reply! I have a 8600k and a gtx 1060 both of which are slightly overclocked. I've tried altering my settings to alot of different iterations but to no effect. I currently have it set to high preset with motion blur off and TAA enabled.

posted in Insurgency - Technical Feedback read more

0_1553898352073_Insurgency Sandstorm 2019.03.27 - 11.53.19.05_Moment (3).jpg So I've experienced this glitch ever since i first downloaded the game. It's like this for every player including enemies. I've tried re downloading the game but nothing worked. I also can't find anyone else online who has had this glitch or a bug similar to mine. [0_1553898271634_Insurgency Sandstorm 2019.03.27 - 11.53.19.05_Moment.jpg](Uploading 100%)

posted in Insurgency - Technical Feedback read more

@gsg_9_lightning I've been dealing with this issue for months now and you just fixed it. The GameUserSettings was set to read only for whatever reason. Thank you so much for helping me! Game on!


Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.