Joined
Last Online
Recent Posts
posted in World War Z - Technical Feedback read more

Maybe for the PS4 you could try the same thing? Normally when you turn off a PS4 or Xbox it goes into sleep mode instead of a hard reset. Maybe worth a try to do a hard reset?

posted in World War Z - Technical Feedback read more

I'm in the United States east coast region. I plug into a wifi access point on gigabit fiber internet. I've managed to get around the issues by restarting the whole computer when the issues crop up. That seems to reset something and does the trick.

posted in World War Z - Technical Feedback read more

I'm actually on PC. I managed to fix the issues by simply restarting the computer whenever it happens.

posted in World War Z - Technical Feedback read more

I've been playing this game a couple days without any issues on PC. But now the game just never loads anything. It takes approximately 10 minutes to load anything (not exaggerating). First it takes 10 minutes to load the lobby. Then it take 10 minutes to join a game. Then it takes 10 minutes to load the exit screen, which at that point you may as well just give up. I've tried verifying the game, as well as uninstalling and re-installing. After re-installation, it loaded quickly until I completed my first round and got to the result's screen infinite load. Then it went back to never loading anything again. It's really making the game unplayable. Any idea what's going on?

posted in World War Z - Technical Feedback read more

I'm also having this problem, but for me it has dialed it up to much more. Now I can't even load to the main screen after starting the game unless I wait for like 10 minutes. Same with loading into a game. I uninstalled and reinstalled, and everything went fast as normal again. Then at the end of one match it went back to an infinite load screen like you. Now everything is back to never loading. I've had no troubles playing this game until just recently. Now nothing loads.