I lose frames every time I ads, which is a massive fault for a first person shooter.

I think you're already aware of this, but I'll post it again and maybe later on record a video.

I have my fps capped to 60fps, however when I ads I lose frame and it drops to 50+ then immediately back up to 60 so long as I remain ADS.
In a first person shooter this is critical, maybe even gamebreaking for firefights.
I find that if I have my fps capped to 120fps and then ads I lose even more frames!! Around 105+fps then it will go back to 120fps.

This happens with all optical attachments. I believe with the 2x scope and above the frames you lose is more than 1x optics.

I also lose frames when I walk into an enemy. Ill like turn a corner, there'll be an enemy right there ... frams drop, I die. It honestly happens every time.

@thehappybub said in I lose frames every time I ads, which is a massive fault for a first person shooter.:

I also lose frames when I walk into an enemy. Ill like turn a corner, there'll be an enemy right there ... frams drop, I die. It honestly happens every time.

I know right. Its just dick optimization, the gun model moves violently and your GPU can't keep up with the change even though I know you GPU is a 980. I've got my game on lowest everything and I still get a small drop. maybe one day it will be optimized ❤

@thehappybub
I think I know what you mean, but when i encounter an enemy like you described I only lose the frames when he starts shooting. I think it's a particle effect rather than seeing the enemy's player model.

Whatever the reason is, its mega annoying. @Slazenger I think you're right with the particle effect because when I go to melee bots from the back, I freeze if they start shooting at another target too.

last edited by thehappybub

For this reason i don’t use scopes above 1x scopes because of the massive framedrops

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.