Constant texture switching in ADS on High Texture Quality

I reported this some time ago but didn't have any evidence for it. Then it vanished for some time, probably because i lowered textures to medium. Recently i increased texture quality to high again, which causes the following visual issues for me (RX580 8GB) in ADS:

Doesn't always happen: Textures in the vicinity switching constantly.
0_1549811172653_ts1a.gif

Always happens but depends on weapon model (M4A1 is not affected as seen above): Some parts of the gun constantly switching textures.
0_1549811228223_ts2a.gif

The texture switching happens roughly in the same timeframe as the gifs indicate.

What Texture Streaming setting do you use? Try OFF if you have not yet.

I have texture streaming on low, will try on high (no "off" setting, but will try r.texturestreaming=0) though i don't believe this is a streaming issue.

It is a Texture Streaming Pool size problem. LOW uses very little of your VRAM. When that small pool fills it starts to unload textures. HIGH is the next setting, but with a 8GB GPU you should use the OFF setting. OFF is the highest setting. It's badly named.

I have the OFF option in my video settings. If you don't have it I think you have to remove your config files and let the game recreate them.
%LOCALAPPDATA%\Insurgency\Saved\Config\WindowsClient

Oh, there is actually an OFF-setting, didn't realize despite playing around with my settings all the time. Will try that out.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.