[Solved]Multiplayer truck selection broken after dlc update?

>>Fixed <<
If you are having this issue remove all empty mods in mod manager and it will fix the ui.

Having issues not being able to select trucks in the mp truck selection. I click to select a truck and the tuck menu closes immediately spam clicking the mouse does nothing. I cannot get that menu to open to select a truck any ideas or anyone else having this issue???

last edited by DrGoNzO1489

The new process to select a custom vehicle in MP is to click "manage mods", then double-click to select a vehicle in the right-hand column. Make sure it says "selected" next to the truck in the right-hand column of installed mods and click OK. Now click choose trucks and scroll down. You should see and be able to now select the modded vehicle you have activated.

My coffee just started kicking in and I realized you are not asking about modded trucks but any trucks in general. LOL

The first thing I would try is to Verify Integrity of Game Files. Often times this will solve odd issues like these.

last edited by PicSoul

@drgonzo1489 Not sure if its related but i had a problem slightly similar to this.
I fixed it by reducing the amount of (custom)maps and/or modded vehicles.
Seems the game can only load up mods whether it be vehicles or maps till some point.

@shadowsincere if that's the case then this game is going backwards.... bunch of crap if you ask me. Every update breaks something... like if it's working don't mess with it! Why change truck selection?! Totally redundant change that now broke mp! You can't join in progress now cause you gotta pick a fucking truck!? I've put thousands of hours into this game modding over the last 4 years and this pisses me off to no end! I have never been able to join games through lobby it always drops someone now that guy can't join cause he can't pick a truck it's a broken system and a redundant change there was nothing wrong with the old system and it needs changed. Why not spend your time syncing lights, mud ,sounds!? Quit wasting our time focus!

Ok guys I fixed it.... problem was related to this issue I guess..... Anyways remove all the blank mods from the list and bam! Ui started working.....wow

last edited by DrGoNzO1489

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.