My game starts in windowed every time...its annoying.

the title says it all. no matter how I close the game....and restarting it, it starts in windowed mode every time.

EDIT - problem resolved in latest patch.

last edited by Max80
Insurgency Sandstorm Community Moderator

That's frustrating. Just to be sure, you go into settings and select Full-screen, are you clicking the "Apply" button? That may explain for it happening every time you launch.

This post is deleted!
last edited by Max80

This bug should be known since alpha. The game always starts in borderless windowed.

@benz I didnt say it starts in borderless window. I said it starts in windowed.

@captain-price Yes I click apply. The way to get it out of windowed mode is to click fullscreen or windowed borderless and then it goes into fullscreen/windowed borderless. Then I have to make sure its in "Fullscreen" after. I can make a video for you if you like lol. I close the game and reopen and its back in "windowed".

I have since moved the game to my boot ssd. Just to see if that was an issue. Insurgency 2 didnt like being on my Data mechanical drive. Also just an FYI I have windows 10 pro.

Insurgency Sandstorm Community Moderator

@max80 Let me know how it goes now that it's on your SSD. The devs said it runs best on your SSD currently. Best of luck!

Hi
I have the same exact problem... It's happening since the first beta.
Every time the game starts in windowed mode - even though when I enter the settings it's still set to FULLSCREEN
So I need to enter the settings, set it to windowed mode (because if I click APPLY to the fullscreen setting shown in the settings nothing happens) , then APPLY then set it to fullscreen and apply the settings again. Geez...
NOTE: when the game starts (windowed) its resolution is set to the same resolution I've set for the fullscreen mode, so it shows as a small borderless window on a 4k screen.
Notebook Asus N552VW, Intel core7, 16GB RAM, Nvidia GTX960M 4GB dedicated, Win 10 64-bit latest patches.
Is there a way to force via command line the launch parameters to fullscreen please?
thanks

last edited by xp

@captain-price its still happening on my SSD. Something to note it wont go to full screen when you try to switch by hitting Full screen. You have to do windowed borderless first to get it to fit screen then switch to fullscreen. And of course, apply changes is used each time.

last edited by Max80

@xp I have no doubt this is being looked at.

Does anyone know the command line parameters for this game? Are those common to all the unreal engine-based games?
I'd like to try to launch the game with fullscreen and rez set via the command line...

last edited by xp

One of the Devs replied yesterday on steam that the game doesn't/can't save the settings and always resets to window/borderless but still showing Fullscreen. After a few minutes, the Dev deleted his post again.
What I want to say with that: They know the problem exists.

thanks for the info 🙂
Curious as to why such a trivial issue should be deleted from the forums...

@xp said in My game starts in windowed every time...its annoying.:

thanks for the info 🙂
Curious as to why such a trivial issue should be deleted from the forums...

I guess it's probably because it is an issue that isn't quite obvious (for example when you have it in borderless window you don't notice it and can miss it) and they didn't want to throw any more confusion and oil into the fire, so to say. They'll just deliver the fix with a patch and be good with it rather just pointing at the error in the forums openly - just my take on it.

last edited by SirPenetrator

Let's hope that by providing as much info as we can about the problem they can nail it for good..

@xp said in My game starts in windowed every time...its annoying.:

Let's hope that by providing as much info as we can about the problem they can nail it for good..

Indeed.
I have collected some amount of bugs and fixes and suggestions - and also this bug, in my other post here on this forum.
Extensive list of bugs (solutions if available) & suggestions of Beta2 - will be updated in the 3 weeks of Beta2

Insurgency Sandstorm Community Moderator

You can skip a few clicks by using the -fullscreen launch option.

You'll still have to go into Video settings @ each launch and hit Apply, but that's all you'll have to do. You won't have to change to borderless, Apply, then back to fullscreen and apply again. Just one click. Not perfect, but it's a little better.

Will try this, thank you 🙂

@prevent said in My game starts in windowed every time...its annoying.:

You can skip a few clicks by using the -fullscreen launch option.

You'll still have to go into Video settings @ each launch and hit Apply, but that's all you'll have to do. You won't have to change to borderless, Apply, then back to fullscreen and apply again. Just one click. Not perfect, but it's a little better.

Hey, downloading a new patch today... Excerpt from the fixes log:

(...)
Optimization & Performance
Fixed an issue where the game was not launching in Fullscreen even if the Fullscreen option was selected in the Settings menu. This would result in players unknowingly playing in the less performant borderless windowed mode which limits FPS to the monitor’s refresh rate.
Added framerate smoothing option in the Settings menu.
Added framerate limiting option in the Settings menu.
Added LODs to vehicle fire particles and further optimized the emitters.
(...)

Will try it as soon as the patch is installed
Hey @Max80, this is for us :)... They do listen.
Full changelog here

last edited by xp

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.