Force feed back issue.

Wheels supported on PC.

Logitech G920 + Driving Force Shifter
Logitech G29 + Driving Force Shifter
Thrustmaster T300
Logitech G27 Steering Wheel
Logitech G Saitek Farming Sim

My buddy is running the G25 wheel, older drivers of course. He is having no issues with Force feed back. 920, is locked at 100% force feed back. I'm almost lifting my damn table up trying to turn the wheel, the known work arounds. (sitting in controls for 10 seconds, or resetting to defaults) does not seem to fix this issue on my end. Drivers all up to date as well.

"""" Question being, is there a fix being developed for the force feed back in the G series? and are there other G users with this same issue.

last edited by Stoned Hippy
Community Manager

Hi there,

We continue to look into issues with force feedback, so I've passed this on to the devs to take a look at for you.

i have the same problem but if u turn the weel a litle bit left and right and click 3-4 times on forcefeedback it will change

did not seem to work, also to note I notice the Logitech software does not seem to even recognize the game. Will not switch profiles even if you manually change it, nothing.

I have the Thrustmaster T150 and the force feedback (in the PC version) doesn't work. It works in other games. I hope this gets fixed.

Community Moderator - Spintires

@unster How exactly it doesn't work?
I know there is a bug with Logitech device, but there is working workaround for that (already mentioned somewhere in here for sure).

The force feedback is dead in this game and on this wheel, as if it's disabled. Only once or twice was I able to get it to work (unplugging the USB cable, disabling & re-enabling the device in the game's menu) but this usually doesn't work and I've given up on it. I also play BeamNG and the same wheel works properly in that game.

I've tried each work around method for my 920 setup. From unplugging the usb while the game was active or not, enabling/disabling force feed back a few times ingame. Turning my wheel sleightly left and right, or even doing a complete end to end 900degree turn. It simply does not recognize the wheel. When talking to logitech support they come back saying Mudrunner is not supported for the 920, so they are absolutely no help at all. Checking the logitech game profiler there is no Spintires mudrunner preset, but there is a preset for the regular spintires game. I redownloaded the original just for a test and know and behold the wheel works perfectly fine. Needless to say i've given up on trying to use force feed back for mudrunner. It too much of a shot in the dark

last edited by Stoned Hippy

I seem to have found a good workaround. If I go to the controls menu and wheel tab, unplug the USB cable, wait, plug it back in, and wait for the game to re-detect the wheel, the force feedback works. I've used this workaround successfully the last few times I played the game. Hoping this gets fixed eventually.

last edited by Unster

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.