PhysX running on CPU...

...which is probably responsible for the most hitches I see on the frametime graph.
Any Chance to run this on GPU? Driver crashed when I tried this.

You can set it to use your GPU in the NVidia Control Panel (under 3D Settings | Configure Surround, Physx).

last edited by Valerian

I know. This is what I tried and it crashed the driver completely. Had to reinstall it. 🙂
So I'm not sure if this is even possible. Perhaps it's CPU only. Maybe someone with more insight in UE4 than I have can say something about this.

I've set it to use my GPU this way without it crashing, it's working fine for me. Must be some other problem you're having than. The driver should not crash doing something simple like that.

How can you tell if the game is using CPU or GPU for PhysX?

In Nvidias driver setup you can set a flag in the upper menu bar under 3D settings.

Obviously the game has to have support for NVidia's PhysX, alas Sandstorm (thusfar) does not ... but a game like Rising Storm 2: Vietnam for example does support PhysX. If you turn the Visual Indicator on an overlay will appear in your game showing either "PhysX -> CPU" or "PhysX -> GPU".

Okay... I was able to make the neccessary settings in the driver for "physx on gpu", however, it's further bound to cpu as the the overlay info shows ingame. Seems there is no other possibility in the moment.
Probably the hitch problem can be solved by an improved parallelization of threads on gpu and cpu.

I had a closer look on graphs of gpu load, fps, frametime and cpu load on a 100ms sample rate via msi afterburner. What I see there seems to follow a pattern. The vast majority of spikes can be explained by events close to the avatar. The shapes of the spikes even tell you what just happens, so it's reproducible. You can clearly see major events like airstrikes, close Combat, explosions or incoming bots into your view. In these situations the gpu seems to starve due to lack of data and the load cuts down from e.g. 80% to 20% or even lower. This takes up to 3 seconds to recover. Result: stuttering. Gpu delivers less frames.

No significant improvement regarding the framedrop issue after sept13 patch. Graphs still look similar under comparable conditions.

SLI still broken.

Hope for the next patch. 😉

After the latest patch I run 144fps at 1080p no stutter no lag, some dips during crazy moment but it stays 100+fps

I have everything on default “low” (the new button that was added in the latest patch)

I have the latest drivers installed and all my Nvidia control panel settings are set for maximum performance. (But no fancy behind the scenes stuff)

I let AI suite do its 4 way optimization and it clocked my cpu to 4.3ghz.

My specs are;
i7 5280k
Gtx 980
16gb ddr4
Samsung Ssd 840 evo
Samsung ssd 850 evo
A-99x motherboard
Windows 10 Pro

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.