Peripheral Support In MudRunner

Same result there, and it doesn't appear among the other devices again.

@lombra Thanks again for the feedback, I really appreciate!
So there is hope to make it work after all πŸ˜„ There must be something I didn't set up right. I'll take another look into the game to find out. I'll keep you updated if I find anything.

Meant to ask, do you use Steam input configuration? I'm not sure whether I do actually, and can't check now, but I think I do not. Any other controllers plugged in or something?

You mean the menu in Big Picture? I do not use it, but I tried once for Spintires and it didn't change anything. But since it was the first time I was opening it, I may not have done things right.
I have a Xbox controller plugged in, but I don't switch it on when I'm using the wheel/F710.

I give up.

I reset the controls, tried with and without X360 Controller Emulator, but nothing works. When I accelerate (with the F710 controller), the wheels go straight, even if I keep steering with the G27. And when I lift off, the wheels turn all of a sudden (the way they should).

And it's exactly the same with an original Xbox One controller.

The fact that it works for you puzzles me. There is almost no in-game settings for the controllers, except the key binding for the wheel. What did I miss?

What's your OS and which version of Logitech Gaming Software do you use?

Maybe you could try using Steam input, and disable the steering joystick on your controller for Mudrunner. I think that should be possible, at least.

Windows 10 and LGS 5.10.
Everybody is up-to-date and working fine with every other sim game.

When I set up the controls through Steam Input, the wheel is not detected anymore in the game (only the controller). I ticked the "Xbox" and "genreric" controller boxes (seprately and together) in the global Big Picture menu ; then I activated the specific controller settings for the game ; and finally I switched to the "global setting" (both for the Xbox and generic controller). Nothing works.

I disabled all joysticks and even the D-pad in Steam Input. I had also done that with X360 Controller Emulator.

Maybe if I could unassign the throttle/brake control under the "wheel" tab in Mudrunner? It doesn't seem possible.

The logitech g29 does NOT work for ps4 on spintire mudrunner. It will work for every other game, you can go to the controls menu and select the shifter/manual gearbox and it will say steering wheel detected but it will NOT work. No buttons will press nothing works at all. The game is not compatible.


i bought the game onPC, last sunday with a thrustmaster TMX force feedback. every thing working good. The feed back response was working perfect... i played all the day

here the issue, i try to play again yesterday, the steering and pedal are working good, but the force feedback does not work anymore... i try to restart my computer do the steering calibration, activate and desactivate the force feedback in the game.... nothing work... i thought it was the steering, so i lauch ATS and the feedback work great.. so i think there is a problem with the game or the config, can you help?

I have a Logitech G-920 hooked up to an Xbox. All the buttons work, but the steering wheel and pedals won’t do anything. Any suggestions?

Hi! My Thrustmaster TMX Pro racing wheel does not seem to want to accept Mudrunner on my Xbox One, or vice versa. Any reason why this would happen? Would like help!

@riley-n said in Peripheral Support In Spintires: MudRunner:

I have a Logitech G-920 hooked up to an Xbox. All the buttons work, but the steering wheel and pedals won’t do anything. Any suggestions?

Having a similar issue, except nothing works with my Thrustmaster TMX Pro. SO ANNOYING!!! 😑 😑 😑 😑 😑 😑 😑 😑 😑 😑 😑

NVM, had to enable wheel primary input!

@riley-n said in Peripheral Support In MudRunner:

I have a Logitech G-920 hooked up to an Xbox. All the buttons work, but the steering wheel and pedals won’t do anything. Any suggestions?

Make sure primary input is enabled.

I have a Thrustmaster TMX Pro and mudrunners will not work with my wheel. I'm on a xbox one. Has wheel support been applied to the console yet?

@van-b I'm having issues as wheel with my wheel, but i have a ThrustMaster TMX. None of my buttons are registering in my game.

@van-b How did you get yours to work? What did you end up doing.

I just bought this game for Xbox. I'm using a logitech g920 wheel. The wheel inputs work, but there is no force feedback or centering force. Also, the game does not seem to have a wheel settings menu. Does this game properly support the logitech g920 or not? I'd appreciate a quick reply.

No full support, plain and simple. If it's a must for you I'd return the game or ask for a refund. I couldn't because I bought the game some time ago on PS4 through the PSN.

last edited by edu27

Is there no way to customize control bindings?
I just went out and bought the American Wilds edition to play on PS4 with my Fanatec CSL Elite wheel.
I have a clutch, but I don't have a shifter.
The game is recognizing my paddle shift as L1 and R1 but these don't change gears, and there is actually no way for me to change gears in this configuration.