unplayble - my mouse is crazy
Focus Team

Please post your configuration:

  1. Press the keys Windows Start (bottom left) and 'R' from the keyboard to open the 'Run dialog box' and type: DXDIAG
  2. Click the button 'OK'.
  3. Post the Windows version (Operating System:), processor model (Processor:) and the amount of RAM memory (Memory:) under the tab 'System'.
  4. Click the tab 'Display'.
  5. Post name of the graphics card (Name:) under 'Device' and the driver date (Date:) under 'Drivers'.
  6. Click the tab 'Audio'.
  7. Post the name of the audio device (Name:) under 'Device' and the driver date (Date:) under 'Drivers'.

the pc is this https://www.msi.com/Laptop/GT72S-6QF-DOMINATOR-PRO-G-29TH-ANNIVERSARY-EDITION/Overview

Microsoft Windows 10 Home 64 bit Ver.1703(OS build 15063.0.amd64fre.rs2_release.170317-1834)

Intel(R) Core(TM) i7-6820HK CPU @ 2.70GHz

16 GB @ 1066 MHz

NVIDIA GeForce GTX 980, 8192 MB

NVIDIA Driver grafico 382.05

Nahimic 2 Audio Driver
Realtek High Definition Audio Driver , 6.0.1.8172
NVIDIA Driver audio HD 1.3.34.15

I have 3 controllers
wheel logitech g25
joy logitech extreme pro
pad saitek p2500 rumble

thanks

Focus Team

Please unplug your gaming controllers (G25 wheel and your two game controllers) before running the game then test.

last edited by FHI HelpDesk

I have the same problem.. Running a Fanatec wheel and pedals (Pedals connected seperately and not into wheel base)
There is a conflict between controller input and mouse movement.. Any slight input from the controller is interfering with the mouse.. have tried unticking 'Use as primary controller' and for a moment the mouse settles, but it seems to re-assign itself as primary soon after.

done, with only the keyboard the mouse work well but I want to play with wheel. but for entering in the truck I have to detach the joy and the pad and with only g25 connected, anyway it remains unplayble because of the mouse without control and for exit the game I have to do ctrl-alt-canc and delete the task https://youtu.be/iOmuYLG3w4c

I'm getting the same thing with G25, but I can control the mouse as long as there is 0 input coming from the wheel.

Same here i have a G920 wheel with gearshift, Logitech joystick and 2 button boxes, unplugging all but the wheel makes zero difference. PLEASE fix this issue as it makes it close to unplayable

these problems are really incredible after I read there where 1000 beta tester, also manual loading is really annoying. I hoped in an improved physic but there is still the lack of the 3rd diff, and even if I lock the diffs, one of the front tire spin anyway. and what about the camera? it is the same as before, maybe worse. thanks for quickly support, but for these problems and other minor things I asked a refund, sorry. maybe I'll give another try some time later

Same problem with mouse goin crazy. I have almost 3500 hrs in Spintires. Most of that with this Fanatec wheel, pedals and shifter. This is a real shame.

last edited by kidsdad72

I have this issue on PC. If I go into advanced mode on the K700 the mouse control fails and I cannot even exit the game from the main menu because the pointer is uncontrollable. ( Main controller is set to G27 wheel ).

Update: I seem to have fixed this by regaining control of the pointer when the throttle pedal was held down. I then got into the settings menu and set keyboard and controller settings to 'default'. I also checked that wheel settings where also default and set to use as primary controller.

last edited by roadster14

Anyone else tried the above workaround and got it working?

@rwb-rygel said in unplayble - my mouse is crazy:

Anyone else tried the above workaround and got it working?

Its not a complete fix but when in advanced mode if the pointer is out of control ( which happens often when you are trying to attach winch) pressing the throttle pedal gives back control. Unfortunately when the attachment is made it drops out of advance mode immediately. It also drops out randomly when you try to change mouse mode and sometimes it clicks a button you are not hovering over.

Sadly, it doesn't seem to work for me..
Any insight into if this is being looked at Devs?.. Other than asking for oppolo's technical specs and asking him to test without controller plugged in (Which he's done) You haven't responded..
Might I suggest in the short term that you could try adding some kind of 'Controller disabled in menus' option? or perhaps point us in the direction of a controller config file so we can have a tinker and see what we can do? The community in general often have some sharp programmers amongst them that can often point out glaringly obvious mistakes or solutions that those who have worked hard on the game might have missed..

This issue caused me to refund the game within 4 minutes 😉
Will come back in 6 month and see, if the bug is fixed.
Meanwhile playing SpinTires again...

This is an absolutely insane problem. My pedal has a bug where it goes to 1% now and then which in all other games isn't enough to cause issue. However hahahaha in Mudrunner good luck clicking anything with the mouse jumping all over the screen. I've had to use an old crappy set of pedals for now which ironically in game still flicker now and then.

And I can't keep it in gear with foot on clutch in advanced menu, again you end up clicking on whatever the game thinks you are trying to move to its so stupidly frustrating.

Simple menu option on or off required: Use controller for menu.

And/or put deadzones in???

Please see similar report (for same problem) here: https://forums.focus-home.com/topic/1863/steering-wheel-issues/9#

devs are asking for feedback with a survey on this issue

last edited by bn880

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.