Unable to load level

I made a simple map in the editor and published it. It shows up in the game and I can chose it in single player maps. When I click start new game I get an error. "Unable to load Level test map1. File is either broken/missing or an old version" Is some trick to getting a mod map to load?

Sounds like your assets were not uploaded properly...are you using custom objects?

Only thing not stock is the rock models from Spun/Nix909. Everything looks fine in the editor but it won't load in the game.

last edited by JustaFordGuy

Did you put the custom objects into their appropriate folders in your level before uploading? the editor will not load custom objects unless manually added to your level folder prior to uploading.

No, I just put them in the editor folders. I'll try to put them in the mod folder tonight and republish it. Do I need to put the standard objects in there to?

Do you still have to create a new terrain under the prebuilt folder and also create a new mod/new terrain? I've seen this back during the beta but I thought that now that maps are supported in the workshop you could just make a new mod/new terrain and then publish?

Here's a nice guide on the map editor in general but also has a good section on publishing maps.

https://steamcommunity.com/sharedfiles/filedetails/?id=1249124522

last edited by PicSoul

I read through that tutorial a few times before I started but it talks about the public beta version of the editor and game needed to do maps. I don't think we need that anymore to do maps right? Doesn't the current editor and game support maps as is?

Anyway that guide shows needing to make a new terrain in the prebuilt section of the editor and then making a new mod/new terrain in the Mod section of the editor. Then manually copying the files from the prebuilt folder to the mod folder. And then publishing the mod. Do I still need to do all that? If so does the new terrain in the prebuilt section and Mod section have to have the same name?

That beta guide is for putting pre-beta maps into the editor so they could be uploaded...no longer needed, unless you started building your map pre-beta. You just need to add the custom assets into their proper folders inside your mod/map/textures&meshes&classes folders prior to uploading. You may have to create the "textures" "meshes" and "classes" folders inside your map folder The editor will load all stock assets without having to put them into said folder. You only need to add the custom assets. If you add stock assets into those folders they will not show up in game.

last edited by Fatboy

Good to know, thanks. 🙂

I took a break for a few months and it seems a lot has changed.

0_1532456268118_Untitled.png

This is what my new level folder structure looks like, of course you need to put the appropriate files into their respective folders.

did it work out?
-i was having the same problem a few months ago. i was using the 'old' way of starting the map/mod.
-Like you described earlier. and had to transfer all my custom model info to the 'map' folders, the editor was not bringing them over with the rest of the info.
-the way to start a mod had changed a little bit ago, started doing it this way and i have had not one problem since.

Hey Guys,
I just copied the custom rock files into the corresponding Mod folders and re-published my map and IT WORKS!!!!

Now I can make my own maps and my own trucks, Super Cool.😎

Thanks so much for all the help.

Got another question. Are you guys getting "out of memory" errors when making a larger map? If i try to create a new terrain and slide the two sliders up a little I get this error.

How big is your map? Are you using the 64 bit editor or Spintires Mod?

I had it before, but can create 1024m maps and 4096m maps with no issue.

I'm using spintires mod. I can do 1024m but any bigger than that and I get the error.

I haven't tried making anything oversized but....I did notice there were back/back updates for Spintiresmod...are you using the most current version? 1.7.8 I think it is. I noticed in the change notes that the newest update addressed objects disappearing on anything outside the normal map size...may have addressed your issue as well, I didn't read all the change notes.

last edited by Fatboy

I'll get the latest one and give it a try.

Does anyone know what size the stock maps are in Meters?

1024m seems really big and it's slow in the editor but maybe it's just my machine.

@justafordguy 64x64 is the stock large map size. that is ~2048x2048

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.