Issue with texturing my dodge truck (and my others)

Hey guys!

Recently, when I go to UV map my truck, everything works just fine... until I go to texture it. I will texture the UV mapped image and everything is fine just until I fire up spin. My truck is one solid or it is black. I did put {RiskyWisky} on the side of the bed on the truck but the whole truck just shows up as black....

I use a .dds format

My file names end with either __n_d __d_a or __s_d

Any help will be greatly appreciated

Sincerely,
{RiskyWisky}

Someone else had this issue, I believe there was a solution to the issue you are experiencing but I can't seem to find the topic to link to you. its here on this forum somewhere, or may have been deleted.

How are you saving the .dds; i.e. are you using the Nvidia plugin or something else? Because I think it may have had something to do with that

I used to use .tga, but then i switched to the .dds format. Also i am using paint.net to do all of my texturing

@RiskyWisky
Which exporter are you using? Axe or kwXport? If you're using Axe make sure the option for TexCoords (think it's under other data, left-hand side of export settings menu that appears when you go to export from Max) is checked.
Also, do you know what the suffixes for the texture filenames mean and what they do?
@Kingpinn
That was me that was having the issue, never did resolve it but I think I know what I was doing wrong, per above. 🙂

last edited by Mexican_420

__s_d means the specular map (sorta like a glow) and __n_d is the normal map, and __d_a is the diffuse map. I have noticed in a bunch of mods the same image file is shared with the diffuse color and the normal map... also i do use the Axe exporter in 3ds max 2018... thanks for the help Mex. Always appriciated

@RiskyWisky
So close...
__n = normal map (aka bump map)
__d = diffuse map (color/image)
__s = specular map (shine/reflections)
__?_a = alpha (transparency usually)
Any of those mods that use the same image for both diffuse and normal maps are done wrong. A quick Google search for normal/bump map should give you a good idea why those 2 types of images/textures are used for totally different purposes...

last edited by Mexican_420

I'm not sure if it will help any, but I found this the other day.
http://spintires.nl/proper-texture-extensions/

I'm pretty sure it applies to MR too. I've noticed, when converting ST mods to MR, that texture files that worked with ST 03.03.16 seem to work just fine with MR(without needing any changes/conversion).

For diffuse textures remove the _a so the suffix reads blahtexture__d.dds

For whatever reason the alpha channel on a diffuse will make the game angry...😕

last edited by DrGoNzO1489

@drgonzo1489 errm...No
directly baked from blender __d_a_uncmp.tga no issues at all and i use them in all of my mods like that
__s_d.tga since the uncmp seems to be disable for the game and same with the uncmp on normals

now I dont use the 4th texture channel (details maps) allot because if i have a Normal why add a details map its just more work for the gxf card

Is that what this goes down to? The texture suffix?

@forces I had this issue and removing the alpha suffix fixed it, just trying to help also risky uses max not blender. I think it would be worth a try

last edited by DrGoNzO1489

@forces The uncmp suffix may help aswell so the editor isn't trying to convert the image

last edited by DrGoNzO1489

what is the "alpha suffix"? the stuff like __d and what not?

I did notice that spun uses something called "Substance Painter". Would that help me?

Picture of my UV mapping >>https://drive.google.com/file/d/1tU0KrnVVc64ICd2hMd3rIU9qOCqPPLsz/view?usp=sharing

Picture of what it looks like in game >> http://steamcommunity.com/sharedfiles/filedetails/?id=1349236192

Grey wasn't the best color to show the truck in, but if you notice there is a semi-light grey in the model

Meshes Xml (base code is Brute's Old Suburban From 2014 Converted)
ANT_001 Is my whole truck model

<CombineXMesh>

<Material
	MeshParts="ANT_001"
	NormalMap="trucks/Brute-Suburban/dodge__n_d.tga"
	DiffuseMap="trucks/Brute-Suburban/dodge__d_a.tga"
	SpecularMap="trucks/Brute-Suburban/dodge__s_d.tga"
	TwoSided="True"
/>
<Material
	MeshParts="Glass"
	Type="matte"
	DiffuseMap="trucks/Brute-Suburban/SuburbanGlass__d_a.tga"
	NormalMap="trucks/Brute-Suburban/NormalMap_n.dds"
	SpecularMap="trucks/Brute-Suburban/SuburbanGlass__s_d.tga"
	Blending="alpha"
/>

</CombineXMesh>

You gotta add your texture as the diffuse not brutes....

I did....

Also if there's more than one material for your model those are denoted like this ANT_001 0,ANT_001 1,ANT_001 2....etc.

last edited by DrGoNzO1489

The editor breaks the model up by material now so if there's more than one adding the mesh pieces like you did only grabs the first one being 0.

That one mesh part "ANT_001" has only one texture to it (one diffuse map, spec map, and a normal map.) There is only one material added to the mesh part...

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.